We are pleased to inform you that the connectivity issues related to the Espanix IXP in Spain have been resolved. All services have returned to normal and the situation has been fully restored. We will continue to monitor the situation to ensure everything remains stable.
Thank you for your patience and understanding.
Posted Mar 26, 2025 - 12:54 UTC
Investigating
We are currently experiencing global connectivity issues in Spain, impacting ISPs (Interner Service Provider) and IXPs. (Internet Exchange Point ) Our team is actively investigating the situation and working with local providers to resolve the issue as quickly as possible. We will continue to provide updates as more information becomes available.
Thank you for your patience.
Posted Mar 26, 2025 - 08:00 UTC
This incident affected: File Storage (Global), Object Storage (Global), Market Place (Global), DNS Service (Global), Virtual PBX (Madrid), DRaaS (Global), Migrations (Madrid), Servers (Madrid), and Remote Desktop (Madrid).